Common Issues

From Era Wiki
Jump to: navigation, search

How do I run on linux?

These instructions were written only for running era games that use Emuera executables that use NET 7 (EE version higher than 35).

Due to a bug with Wine, you need Wine staging or Proton 8.0 to run these games so use the staging branch when installing wine.

  • Install wine and winetricks
  • Avoid the packages from your distro, these are almost always very outdated, particularly so winetricks.
  • Run WINEARCH=win64 WINEPREFIX=~/.wine64_era winetricks fakejapanese
  • Download the NET 7 Desktop Runtime x64 and install with wine `WINEARCH=win64 WINEPREFIX=~/.wine64_era wine windowsdesktop-runtime-7.0.XX-win-x64.exe` (Replace XX with the download version)
  • (optional) get a copy of msgothic.ttc from a windows install and paste it into ~/.wine64_era/drive_c/windows/Fonts/
  • Without the msgothic font, the text in the game will look like a mess due to wine using a fallback font, you can alternately use your own monospace font with the game
  • Your prefix is ready, run the game with: DOTNET_ROOT="C:\Program Files\dotnet" WINEARCH=win64 WINEPREFIX=~/.wine64_era wine ./Emuera1824+v18+EMv17+EEvXX.exe (Replace XX with the current version used)

If it still doesn't work, try running it through Lutris with "Wine version" set to "Proton - Experimental".

How do I hook text?

You don't hook eragames. They automatically copy the most recent message on screen to your clipboard, which you can paste directly into a translation tool. ChiiTrans/Translation Aggregator/Sugoi automatically read from the clipboard.

dotnet refuses to install ("already installed") or Game crashes at launch with "narrow/wide" errors.

Uninstall wine-mono via winetricks.

My game starts, but the screen is white with a black cross. (Missing renderer)

Install d3dcompiler_43.

Images fail to load. (EmuEra EE)

Use a 64-bit prefix or replace libwebp.dll with an older renamed libwebp_x86.dll.

Game crashes frequently! (EmuEra EE)

Use a 64-bit prefix.

Help me, my game crashes when I launch it!

Go scream at the people in the thread or on discord, they'll help you. Make sure you save any error messages it spits at you.

The text is misaligned

Use Japanese locale, or scream enough, I think there exists an anchor somewhere that fixes that, but it crashes old megaten saves so there's that.

I found a bug, wat do?

Go here and report it please.

Which branch/version do I download?!

Usually you'll want to grab eng-development (Latest updates with /egg/ bugfixes/additions, eng-translation usually doesn't have these) or eng-release (Stable releases but slightly behind).
If the game doesn't have those branches, grab the master branch. That's it.